User Guide: Operations & Workflow

GIGAamacro
GIGAmacro Magnify2 and Control Box
Magnify2

Published by: GIGAmacro, 455 Technology Way, Napa, CA 94558, USA +1 415 841 3322 (Pacific time zone)

Author: Graham Bird
Suggestions, improvements and updates to: <[email protected]>
Version: 2.0, Version Date: 2017-10-19

Tips and hints are indicated like this.
Warnings are indicated like this.
Critical or important items are indicated like this.

Introduction

The GIGAmacro Magnify2 makes it easier than ever to produce your own gigapixel macro images of a subject or specimen. We have simplified and streamlined the production workflow, though producing the very best image requires practice, skill and attention to detail. We recommend that you become thoroughly familiar with the hardware and operations and study the user guides for both Zerene Stacker and Autopano Giga and try a few practice runs before starting important work.

How to make GIGAmacro Images

Gigapixel macro images (GIGAmacros) are constructed from many hundreds, or more often, thousands of individual photographs. These photographs are captured using the Magnify2 and then digitally combined to create a seamless gigapixel image.
 In this process, you will digitally combine the photographs using the "Stack & Stitch" methodology. First you will "stack" the individual photographs from each XY location to increase the depth of field and then "stitch" the resulting composite images together to create an ultra-high resolution, deep-focus image.

Photo Matrix for Stacking and Stitching

Focus Stacking

Focus stacking is a technique which combines multiple photos taken at different focus distances to give a resulting image with a greater depth of field. We use Zerene Stacker, one of the best focus stacking software packages available, in the Magnify2 system.

Focus Stacking Example

Image Stitching

Image stitching or photo stitching is the process of combining multiple photographic images with overlapping fields of view to produce a segmented panorama or high-resolution image. Autopano Giga is one of the most advanced and powerful professional stitching software packages available. Autopano Giga is included with the GIGAmacro Magnify2 system.

Stitching Example

Viewing Images

The final GIGAmacro image can be explored using the GIGAmacro Viewer, which has been designed specifically for gigapixel imagery. GIGAmacro Viewer makes use of tiled-image viewing technology, similar to that used in mapping web sites. This technology allows for extremely large images to be viewed online in a browser on any computer or mobile device that is connected to the internet. The GIGAmacro Viewer can be used for sharing, analyzing, and comparing multiple GIGAmacro images. It is specifically designed for high-resolution macro and micro photography.

GIGAmacro Viewer

Using the GIGAmacro Viewer you can:

  • Use the GIGAmacro Viewer in demonstration mode to show images automatically

  • Use GIGAmacro images in your exhibits and/or your curriculum

  • Make side-by-side comparisons

  • Link GIGAmacro images together for synchronized movement

  • Make layered comparisons in “x-ray" mode

  • Take measurements on an image

  • Flip GIGAmacro images vertically or horizontally

  • View in fullscreen mode

  • Use and view GIGAmacro images on your own intranet or on internet website or cloud service

  • Load GIGAmacro images from your local hard drive or cloud storage

  • Load gigapixel images from a Zoomify or Gigapan tileset.

Getting to Know Magnify2

The complete Magnify2 consists of a Control Box, robotic camera rig, computer and LCD screen. All standard system configuration options are covered in the appendices to this Guide. Once connected (the system should be set up during the installation process, but if not see the Power and Leveling appendices at the end of this Guide), the system only needs adjusting to accommodate the particular subject or specimen(s) being photographed.

Annotated Magnify^2^

Specific parts of the Magnify2 are labeled in the diagram above.

It’s important that you become familiar with the operation of the machine before using it.

The Magnify2 has three axes of movement: the X axis is left to right; the Y axis is back to front (labeled in GIGAmacro Capture as 'Top' and 'Bottom' respectively); and the Z axis, which moves the camera assembly, is labeled in the GIGAmacro Capture application as “High” and “Low”.

Magnify^2^ Axes
Even though there are limit switches on each axis that prevent movement beyond the specified range, it is possible to mount the camera BELOW the range limit on the Z axis. This means that a subject on the scanning table, or the scanning table itself, could be damaged if the camera is driven too far down. Take extreme care with positioning and the “LOW” control!

If the Magnify2 camera and system are already setup and configured, you may jump ahead to the [Workflow] Overview.

Attaching the Camera, Flash and Mounting Arm

Attach the lens to the camera (the standard system is a Canon TNi with the MPE-65 macro lens, shown below).

Ensure that the power adapter is installed in the camera with the power cord emerging from the battery compartment. Make sure that the LCD screen is rotated (on cameras such as the TNi) so that the screen is viewable.

Locate the arm assembly.

The camera is secured to the slide by a screw, and you will need a small coin, (a quarter will do), to tighten the screw. The camera back and LCD should rest firmly against the block on the slide when the camera is correctly mounted.

si 015 edit

si 016 edit

Locate the camera flash system. Check that the flash control unit has the power supply installed and that the external power cord is coming from the battery pack cover.

si 016a edit

Attach the flash control unit to the camera and gently tighten the securing ring.

Attach the flash heads to the mount screws on the end of the arms (see arrows, below) and tighten finger tight.

si 018 edit

Mount the Camera and Arm Assembly

The whole camera, flash, and arm assembly is now mounted onto the Magnify2 by sliding the camera plate into the receiving plate(s) on the Z axis, from below.

Drive the rig high enough on the Z axis to give yourself plenty of clearance to maneuver the arm assembly. Fold the Magic Arms and flash head close to the arms during mounting.

Ensure that the unit slides high enough to engage the safety pin (press the pin to release the assembly when lowering or removing it). This ensures the unit cannot drop out, even when the locking lever is loosened. Rotate the locking lever to secure the arm assembly in the desired position.

si 019 edit

si 020 edit

The arm assembly slides UP into the receiving plate(s), and can be secured to the upper or lower plates or straddling both plates. Ensure that when the arm straddles the plates both locking levers are tightened.

Workflow Overview

The workflow below may look, at first glance, a little forbidding! However a little familiarity and practice will enable you to quickly and accurately set up the system and produce gorgeous images.

There are three stages; SETUP, CAPTURE, and PROCESSING detailed below.

The longest part of the process by far is fully automated. The capture can take a few minutes or many hours, depending on subject size and final resolution, but the system can be left unattended to complete that task after setup. Stacking the images can also take time, but again the batch processing can run unattended once setup.

This guide assumes that the capture and the post-capture processing all take place on a single computer. However, especially in a high workload situation, it may be desirable, or even necessary, to have a second (optional) computer system to perform post-capture processing. We can advise you on the specification for such a system if required.

Process Steps

  • Select the subject or specimen(s) to be photographed

  • Prepare subjects for photography - this will vary greatly depending on the type of object, its size, the number (you may choose to “template” a number of specimens), the background ( neutral grey, white, black, or just glass).

Templates are available for a wide of subjects such as microscope slides, geological thin sections, insects, etc. or custom templates can be custom built to your needs.
  • Decide on the resolution you want for your final image - remember high resolution images mean more photos, and smaller objects at high resolution means the largest number of photos.

  • Check the camera settings and flash settings

  • Position the subject, secure it if necessary

  • Set the capture parameters in GIGAmacro Capture: project name, metadata, boundaries, exposure, etc.

  • Set the magnification and depth of field in Capture

  • Set the lighting

  • Make test exposure(s)

  • Run the capture

  • Focus stack the images using Zerene Stacker

  • Stitch resulting focus stack composite images using Autopano Giga and render to .psb file

  • Cleanup image in an editing program of your choice (for example Photoshop), if required

  • Render image tiles, zip them into a single file

  • Upload to web server for browsing

  • Archive originals, intermediate and final image, and tiles.

Detailed Operation

The Control Box should be located in a position that is convenient for quick access to the power switch (the flip switch on the left) and the Motor Rapid Stop (MRS) button (red, on the right of the Control Box.)

Magnify^2^ Control Box

The Motor Rapid Stop button will instantly stop all stepper motors when pressed. Power to the rest of the system is maintained, so that a photo capture may be restarted when the problem is resolved. To re-arm the MRS it must be rotated to the right and then it will spring out to the normal operating position.

Power Up the System: (power down in reverse order)

  • Turn on mains power at the power strip

  • Turn on the computer and screen

  • Turn on the power switch on the Control Box

  • Turn on the LED light (if fitted)

  • Turn on the camera and flash. Note: Camera and flash should be in “Manual” mode to operate correctly (“M” on the camera dial, see Appendix for camera settings). Check that the lens is set to ‘Manual Focus’.

The flash ALWAYS powers up in ETTL mode. It must be reset to Manual mode, and the power set at 1/64, each time.

Launch Capture Software

The capture process uses two software packages that work in conjunction with each other: DSLR Remote Pro for camera control and GIGAmacro Capture.

Click on the DSLR Remote Pro icon in the Windows Taskbar (see diagram below). The camera will show as “connected” at the top of the window once the application is open (if it doesn’t show “connected” see the troubleshooting Appendix).

Launch GIGAmacro Capture using the icon in the lower left of the desktop. GIGAmacro Capture communicates both with the camera via DSLR Remote Pro and also manages positioning of the camera system on the rig in three-dimensional space.

You should now have a desktop that looks like this:

Desktop with Capture & DSLR Remote Pro

GIGAmacro Capture

This Guide gives an outline of the whole Operations & Workflow process for the Magnify2. For a full description of the functionality, options and use of GIGAmacro Capture, see the “GIGAmacro Capture User Guide”. Most settings are pre-set for you and you should not need to change them. You can explore the nuances and additional features later!

System Startup Tab

The Startup tab allows you to connect to the Magnify2. Click the Start Communication button. The red/green button will indicate if a successful connection is established.

If no connection or movement is possible, check all cables and repeat the process. In some cases, you can unplug the USB cable, wait 10-15 seconds, then plug the cable back in to reset the connection if necessary.

You can explore the GIGAmacro Capture screens and settings without being connected to the Magnify2: simply press the “Start Imaging” button and explore.
alt

System Settings and Presets

You do not need to change anything at this stage, but if you wish to, click the System Settings button to access the defaults for the system and make changes (for example to change the location where Capture photos are stored): don’t forget to save any changes you make.

Do NOT change any settings other than 'File Management Presets' unless you really (we do mean REALLY) understand the effect), or when talking to support.
ow 016

Project & Queues

The Projects & Queues tab allows you to save, load, and reuse both individual projects and entire queues (queues are collections of projects, used, for example, with the GIGAmacro template system) when batch processing.

This tab is where you name the project and enter details and metadata of the subject, who ran the project, etc. Though you can change the location of the folder where your projects are stored, we recommend in your DATA folder.

We create pre-set folders called !Projects and !Templates in your Data folder

In this case you will setup and run a single (test) project. Click “New Project”. Give your project a name, fill in the Subject ID (if you so wish), and fill in the Created By field. The date is automatically completed and you may add any notes as you wish.

Click the “Add Project to Queue” button.

Position the Subject and Camera

Position the subject in the center of the imaging area and determine the best orientation for it. The final image can be rotated and adjusted later, but it is always best to start with a centered and well positioned subject. Use the GIGAmacro Capture software controls to position the camera directly over the subject. Positioning controls are at the bottom left of the Project Capture Area, circled in red in GIGAmacro Capture image, above.

There are three ways to change the position:

  1. Use the left, right, front, back, high, low buttons to position the camera.

  2. Type in a number in the x, y, or z boxes to go to a specific position.

  3. Ctrl + Left-Click on a location in the photo in the Project Capture Area to go to that position. This only works once you have taken a photo and it is displayed in the Project Capture Area (see image above).

Adjust the Lens

The lens in the system is used as though it is a fixed-focus lens. The camera and lens are moved closer or farther from the subject in order to move the fixed-focus point to focus at a particular location. The examples here assume the use of the lens shipped with the standard system, the Canon MPE-65. If you use a different lens, the principles are identical although the lens controls may differ.

There is an important distinction between focus and magnification. Magnification is set by rotating the “ring” on the MPE-65 lens itself to adjust the magnification. It may seem as if you are changing focus when you do this, but in reality you are changing the magnification or “Field-of-View”. To change magnification rotate the adjustment ring on the lens. To change focus, position the camera and lens closer or farther from the subject using the GIGAmacro Capture controls to move the rig HIGH or LOW. Coarse adjustment can be achieved by adjusting the quick release plate which holds the camera.

*Check, and update as required, the field of view and depth of field setting whenever you change the magnification and/or aperture of the lens.
You can check the actual Field of View by taking a photo of a ruler and counting the millimeters in the resulting photograph. *

These settings are displayed and updated in the "Set Field of View" tab in GIGAmacro Capture.

ow 017
Ensure that the Camera, lens, field of view and depth of field are all accurate. MANY of the stitching errors or poor results we see are because of errors or mismatches between the camera/lens settings and the settings in this tab.

Set the Boundaries

The boundaries are the outer limits of the subject (or part of the subject) being photographed. Move the camera to each of the six boundaries (left, right, top, bottom, high focus, and low focus) and press the appropriate “Set” button to 'lock' each boundary.
The live view window can be used to see what is currently in view as you move the camera. Click the LiveView "On" button to see the real-time view from the camera.

LiveView turns off each time you change a setting on the camera or in Capture. Simply turn LiveView on again to resume real-time image viewing.
ow 018

Set the Lighting & Exposure

Correct exposure is one of the keys to great images and though this guide will not cover digital photography technique in depth (we’d advise you to work with someone who does have some photography expertise, or learn the basics yourself), we’ll mention some important considerations.

You will use flash, the Canon MT-24 Twin Lite, to light the subject. Each time the flash is switched on, it sets the Mode to ETTL (that cannot be changed, unfortunately); you will need to change it to Manual and set the power. 1/64 power is a good starting point for your trial exposures. Each flash-head can be positioned independently to light the subject. Use standard photography techniques to light your subject well: side or raking light to bring out detail, diffused lighting from above to flatten or evenly illuminate the subject.

You can see the GIGAmacro Diffuser option on our web. You may also wish to use GIGAmacro Cross Polarizing to help with lighting.

ow 019
Two key tips: light drops in intensity as you move the light farther from the subject as per the inverse square law shadows and detail are “sharper” when lights are positioned farther from the subject;
shadows and detail are “softer” when lights are positioned close to the subject.

The cycle is as follows:

  • Make a test exposure,

  • Adjust lighting and/or ISO and/or diffusion

  • Make a test exposure

And repeat until you achieve the desired lighting and correct exposure.

To adjust your exposure make changes to ISO (we recommend 100 to start), and aperture (within the limits mentioned below), set the flash power and then adjust the lighting position to fine tune the exposure.

Always use the lowest ISO that achieves the exposure you want.

To conserve disk space and speed post-capture processing we ship your camera set to JPEG LARGE FINE quality. We have found that the simplicity of capture and processing of JPG photographs is sufficient in the vast majority of circumstances. However, if you wish to use the RAW format to allow a more precise and in-depth control over post-capture processing, for example for color balance, you may do so; the additional processing steps required are beyond the scope of this guide; see our web or contact support.

Take plenty of test photos of different areas of your subject to evaluate the best lighting and exposure conditions. Note these key concepts about exposure settings:

  • Use the histogram to evaluate the exposure and use conventional digital photography practices to avoid under- or over-exposing your photograph. Remember that you should evaluate both the lightest and the darkest part of your subject (at the selected Field of View) to select the "right" exposure.

  • Shutter speed should be kept between 1/60 and 1/200. Shutter speeds above 1/200 may not sync correctly with the flash, resulting in an image with a dark “stripe” along the long edge of the frame.

  • Aperture (or fstop) should be kept between f/5.6 and f/8. A lower number for your aperture (larger opening) will result in a shallower depth of field and will require more images in each focus stack. A higher number will result in greater depth of field and will require fewer images.

If you are an experienced photographer, you may be tempted to use a smaller aperture to get maximum depth of field. However, a smaller aperture will also result in more diffusion - making images appear softer. There is a 'sweet spot' for each lens and GIGAmacro’s research shows that the best trade-of is using apertures between f/5.6 and f/8 for the standard MPE-65.

By now you should have everything set. Your final step is to update the project information in the Project Queue with any new boundaries and exposure settings. To do this, return to the “Projects & Queues” tab, and click the “Update Project in Queue” button. You may also “Save Project” if you wish.

Capture the Photos

The Capture Photos tab allows you to run the automated capture process and select options for this capture. For this test you do not need to select any of the options on the left; your starting position should be 0, optional delay 0, with the Project loaded into the Queue, and click the start/stop button.

In some circumstances - such as when using higher flash power - you may need a small delay. Experiment with values between .2 seconds and 1 second
ow 020

Grab a coffee, when the capture finishes, you will start the post-capture processing steps! You can see an estimate of the time to complete the capture in the lower middle of the “Capture” tab, “Capture Progress”.

Post-Capture Processing


Once the capture is complete you are ready to process the photos. This is the magic that combines all of the photos into a single, seamless, gigapixel macro image. Adobe Photoshop is a useful (optional) package for image cleanup and for producing Tiled-image Sets. It is not shipped as part of the standard system. There are various package options available and you should study the options carefully before choosing.

File Folder and Naming Convention

The photos that are captured are automatically organized and placed in folders. The main folder (located in the 1_Capture folder of your Data location) is the name you gave to the project, with date and time appended. Sub-folders inside the Project folder contain each of the “stacks” of photos. These stack folders are named as follows: col_0000_row_0000. There will be a folder for each row (Y) and column (X) in your project. Each folder for an XY position will contain the number of photos needed to give sharp focus for the whole depth of the subject, as you selected by setting the high and low boundaries. The number of folders is equal to the number of positions in your complete mosaic (X by Y). Inside each sub-folder, the individual photos are stored for the (Z) stack at that location in the mosaic. The illustration below shows this diagrammatically.

Photo Matrix for Processing

The following steps use commercial software to stack, stitch, edit and finally tile the images for use in the GIGAmacro Viewer. Each step uses a specific software package which is rich in features and requires time and study to learn to use fully. The steps included here are, of necessity, the simple ‘big picture’ view. To get the best out of your captures, please study the detailed user guides and reference manuals for each software package, they are included in the C:/GIGAmacro/User Guides folder of your computer.

Zerene Stacker is used to process the photo stacks and is included with your system.

Autopano Giga is used to stitch the images into a single large gigamacro image. Autopano Giga is included with your system.

Adobe Photoshop is an optional package that is useful for image editing, cropping, etc.

Post-Capture Processing Step 1: Stack the Images

This process takes each stack of photos (taken at different focus positions) and merges those together into a single image which is sharp throughout the whole image.

Atomated Processing

  • Open Zerene Stacker

  • Select "Batch>Load Batch" and navigate to the Project folder. In each completed Project there will be a file called "zerene_batch_script_Project-Name_MM-DD-YYYY_HH-MM-SS.xml". Select this file and load it into Zerene. You may now click on Process This Batch, or Process All Batches and stacking will proceed. Get more coffee!

You can add multiple Projects to stack to a batch. The process is a little cumbersome to add them. Close the Batch dialog, and choose Batch>Append Script. Repeat until all are required Projects are added.
If you have moved the folder prior to stacking, the batch file will NOT work. This is a restriction of Zerene (at this release) that uses absolute pathnames.
Manual processing is practicable, but is beyond the scope of this document: see the Post-Processing User Guide for information about manual stacking.

Post-Capture Processing Step 2:

Stitch the Images using Autopano Giga
. This process takes the composite (stacked) images and merges them together into a single seamless image.

Open AutoPano Giga

  • Import the images you wish to stitch (use the Gigapan importer) - they are in the Project folder.

Autopano may not correctly interpret the number of rows and columns. Note the number of rows and columns when selecting the images to import, and carefully check that the dialog has the correct numbers for each. You may find that the column and row counts are reversed
  • Review the stitched image and make any changes required. Often cropping is required!

Cropping in Autopano reduces the time to render the .psb output image. It might seem that you could crop in Photoshop, but our strong recommendation is to crop as much as possible BEFORE rendering.
  • Render the image to Photoshop (.psb) format.

  • If prompted, Save All.

Your system will have preferences already set to name the rendered file to the name of the Project and place the file in the Project Folder.

If you need or choose to process the file in Autopano again, Autopano is set to identify each version with a sequential serial number, e.g. 000, 0001, etc.

Optional Post-Processing Step 3: Editing the Photoshop image if needed.

You can edit the image if needed to make any desired corrections or cleanup to the image.

The image at this point is very large in size and may take a while to load into Photoshop depending on the image size and the speed of your computer. Operations here are slow; please be patient.
  • Open the Photoshop .psb format image you created earlier in the process.

  • Edit as needed to adjust for e.g., spot removal, levels, cropping, or color balance corrections.

  • Save as a Photoshop image. Use a naming convention such as “myimagename_20000x10000.psb” where 20000 is the width of the image in pixels, 10000 is the height of the image in pixels.

Post-Capture Processing Step 4: Tile the Image for Online and Offline Viewing

This process takes the image and produces a set of “tiled” images for fast rendering and viewing in a browser. Enter any text information about the GIGAmacro image. This can be edited later if needed. Upload the image tiles to your server, or to your file storage.

Uploading can take some time. If you are using ftp to move the tiles to a server, a tip is to ‘zip’ the images into a single file, and unzip it when in the final location. This can reduce upload time considerably.

Post-Capture Processing Step 5:

Go celebrate and view the image online or offline using the GIGAmacro Viewer!


Appendices

Connecting Cables & Computer to the Rig.

NEVER connect or disconnect any cables when the Control Box is powered ON. Disconnect the power connector before making, or undoing, any connections.

si 022

Each of the cables from the Magnify2 Rig will be connected to the Control Box. You will see that each Control Box connector is color coded; note that some connectors have two colored bands, some have one. Each cable has a identical coding at the end of the cable by the connector. Connect each in turn and secure with the screw locks.

You will have three cables which are not yet connected; the 2.5mm plug is unmarked and connects to the unmarked 2.5mm socket on the back of the Control Box.

When completed, the back of the Control Box should look like the illustration below.

si 023

Now plug the Control Box power cord into an outlet.

Place the computer and monitor in a convenient location and connect the power cord, the network connection, and the connector between the computer and the LCD display. Connect the keyboard and mouse. Connect the power cord for the LCD display and power up the system. Confirm that the computer is working, has internet connectivity etc.

Now connect the Magnify2 system to the computer. Find the USB cables in the cable bundle (there will be two, one is a spare for future use), and connect them both to USB ports on the back of the computer.

Note the colored tag on the end of the USB cable you will need to connect the camera to the other end of the same cable on the gantry.

Find the separate USB B-type cable with a square connector on one end and a regular USB connector at the other. Connect the square end to the Control Box and the other end to a USB input on the back of the computer.

si 024 edit

ENSURE THAT THE CABLE BUNDLE FROM THE RIG TO THE CONTROL BOX IS WELL SUPPORTED, AND THAT THERE IS NO TENSION ON THE CONNECTORS & CABLES AT THE REAR OF THE CONTROL BOX.

Camera & Flash Connections

Now for the camera and flash connections. At the front of the Magnify2, (note: the camera arm assembly is omitted for clarity), connect the flash and camera power supplies. These are color coded in a similar manner to the other cables.

si 026 edit

Check the power cable is connected to the MT-24 Flash unit, and attach the flash to the top of the camera. Check that the remote trigger cable is connected to the camera.

Locate the camera mini-USB to USB connector and plug it into the USB cable that you earlier connected to the computer (one USB cable is a spare, check the color of the tag on the back of the USB cable in the computer if you are unsure which one it is). Plug the other end into the Plug the other end into the mini-usb port on the camera.
 The 2.5mm Remote Connector cable plugs into a camera specific connector or cable. Connect the 2.5mm jack to the appropriate adapter/cable for your camera - the default configuration Canon TNi uses a sub-mini plug - and connect that to the Remote socket on the camera.

Double check all connectors and fastenings.

Check power cables and connections.

Once you are confident that all fastenings are secure, and cables are correctly connected, you may power up the computer.

Power up the Control Box using the flip switch on the left side. Ensure the camera and flash unit are switched on and have power.

Date: 2017-10-19


Leveling and Scanning Table True-up

It is important that the gantry is truly vertical and that the scanning table is orthogonal to the camera & lens.

This whole process is easier and quicker with two people.

You will need a level (if you don’t have on, a phone and a spirit level app will do), the supplied wrenches, Allen keys and something thin and flat - we use a nice thin mousepad or an optical target - that has an image on it that can be brought into sharp focus. If all else fails, a piece of paper with a mark such as a cross in a circle works just as well!

The first step is to ensure that the gantry is vertical. In order to do so, ensure that the Magnify2 is on a table that is stable and reasonably level. Remove the glass scanning table and place it safely aside. From the front of the Magnify2, locate the bolts on the left arm pivot and using the appropriate Allen key and wrench, slightly loosen the bolts. Do the same for the matching bolts on the right pivot arm. With the pivot bolts slightly loose, use a level and move the gantry until it is perfectly vertical. Tighten all the pivot arm bolts and recheck with the level.

Carefully slide the glass into position and, if necessary, adjust the side buffer stops so that the glass is both square with the frame and held gently in place by the buffers. When you adjust the buffers DO NOT turn the rubber buffer; instead use a wrench to carefully adjust the nut behind the buffer. There are four rubber buffer adjustment points, one close to each corner, see photo below. There are also four supports and it is these that are adjusted slightly to ensure that the scanning table is completely orthogonal to the lens. It is also helpful if the Magnify2 is completely level, though a small error is not a problem.

si 027 edit

To adjust the scanning table we are going to place our test subject (remember the mousemat?) in each corner in turn. When the subject is precisely in focus at each corner, then the scanning table is correctly adjusted.

Here’s how to set up the Scanning Table

Place the subject in one corner of the scanning table. Drive the camera to one corner in a position that it is directly over the subject. Drive the Z axis so that the subject is precisely in focus. Click the ‘Home’ button for the Z axis, which will lock in the datum (zero point) to the GIGAmacro Capture software.

Now we have a datum and we will use that datum to align each corner in turn to that datum; we do this by driving the camera to the next corner and checking if our subject is in focus. If it is in precise focus, that corner is OK and you may move to the next.

When you find a corner that is slightly out of focus, drive the Z axis so that the focus is precise and note the change, measured in mm, in the GIGAmacro Capture window. That is the amount to adjust the glass support (use the supplied wrench) up or down. Each full turn of the support screw is about 1mm.

Repeat the process for each corner until you can drive the camera around the scanning table and the focus is correct - sharp - in every corner. When you achieve that, your true-up is complete.

Date: 2017-10-19


Canon T2/3/5/n/i Settings

This is a brief description of the recommended settings for Canon DSLR cameras. The menu structure varies depending on the Mode Dial setting and is similar on all Canon models, with the more sophisticated models having many more settings.

Most automation is turned off, as the camera is driven by the GIGAmacro Magnify2 to move to each location that a photo is required, the exposure made (and downloaded to the computer) and the rig moves to the next location.

Ensure that the camera is switched on, and Manual mode is selected.

Press the Menu button and check (and set if not as indicated):

Quality = LARGE FINE JPG
Beep = Disabled
Release shutter without card = Enabled
Peripheral Illumination = Enabled
Image review = Off
Red eye = disabled
Auto Lighting Optimizer = Disable
Color space = Adobe RGB
Picture Style = Neutral
Histogram = RGB
Set the date and time correctly
Custom Function 3 = 1/200th (flash synch speed)
Custom Function 4 = Off (Long exposure noise reduction)
Custom Function 5 = Disable (High ISO noise reduction)
Custom Function 6 = Disable (Highlight tone priority)
Custom Function 7 = Disable (Autofocus beam assist)

Date: 2017-10-19


Troubleshooting

No Power to Magnify2

  • Switch off Control Box and disconnect power

  • Check all connectors on the back of the Control Box are correctly located (check color codes)

  • Reconnect power cord and switch on Control Box.

One (or more) Magnify2 axis doesn’t move.

  • Check connector cables (see ‘No Power’, above)

  • Check that each axis is not at the extreme end of its travel

  • Check the limit switches - there are six switches, each should have a small red light. Two are on the gantry, two on the Z axis and two on the left hand (from the front) side of the Magnify2

  • Check that the Motor Rapid Stop button is NOT pressed (rotate clockwise to release)

  • In GIGAmacro Capture, check ‘Settings’ and Stop serial connection, then Start the serial connection.

Noise when Magnify2 is moving.

  • Check that nothing is obstructing each rail

  • Check connector cables (see ‘No Power’, above)

  • In GIGAmacro Capture, check ‘Settings’ and Stop serial connection, then Start the serial connection.

DSLR Remote shows “Not Connected”

  • Check USB plugged into camera, to the connector on the gantry, and to the computer

  • Check that external power is plugged into the camera

  • Check that the camera is switched on

  • Check camera LCD screen for errors

  • Confirm in DSLR Remote Pro that Camera>Auto Reconnect is checked in the menu

  • In DSLR Remote Pro Camera menu, click Connect Camera.

No Power to Control Box

  • Switch off Control Box and disconnect power.

  • Check all power cables, confirm that there is power at the outlet (plug in another device that is known to work).

  • Reconnect the power cable.

Camera connected, won’t take a photo

  • Check that Shutter Release cable is connected

  • Check that camera is in Manual mode

  • Check that focus is set to manual on lens (if appropriate)

  • Click the ‘Release’ button in DSLR Remote Pro

  • Check Capture presets (folder location for captured photos, etc.)

  • Check camera LCD screen for error messages

  • Check that you have sufficient disk space where your project is saved. If you are saving to a network drive check that it is connected and accessible.

Camera Flash not firing.

  • Check that the flash control unit is correctly on the hot shoe, with locking ring finger tight

  • Check that external power is connected to camera and to flash.

  • Check that camera and flash switched on

  • Check the USB cable (from camera to PC)and remote trigger cables are connected.

After all these checks, If none of the above solves your problem, please call GIGAmacro support at +1 415 841 3322, and / or email [email protected]. Support is based in the US Pacific timezone (GMT -8 hours) and is available 9am - 5pm.

Date: 2017-10-19


Zerene Settings

Zerene Stacker is used to create the composites that are stitched into the final image.

Zerene Stacker settings CAN be saved and the "standard" settings which we ship on a new system are available in the C:/GIGAmacro/ folder of your system.

To load the settings, start Zerene and choose Options>Preferences. On the lower right of the Options>Preferences box, click on 'Load', and navigate to your preferences file.

The default Preference settings are saved in The GIGAmacro/Settings folder on your computer. When selected, click 'Open' and the default preferences are loaded; click 'Apply' and then 'OK'

If you experiment with settings, or have more than one file for settings, these can be saved via the Options>Preferences dialog box.

If you save your own settings, e.g. to produce a depth-map as well as an optical image set, be sure to save the file with a meaningful and NEW filename, otherwise you may overwrite the default file.

Date: 2017-10-19


Autopano Giga Preference Settings

Unfortunately there is no way to save and restore settings in Autopano, so they must be set in each preference panel.

In (Windows) Edit>Preferences set each of panels as illustrated in the example below. The panels are slightly different depending on whether you are using version 3.x or version 4.x

We strongly suggest that you study the APG User Guide and understand the impact of changing these (default) settings for use with the Magnify2.

Version 3.x

alt
alt
alt
alt
alt
alt

Version 4.x

alt
alt
alt
alt
alt
alt
alt
alt

Date: 2017-10-19